[Laravel] 配置phpstorm支持laravel语法补全

[Laravel] 配置phpstorm支持laravel语法补全

QAQ 不得不说,想使用我喜欢的vim来完美的做到larvel的智能补全太难了(以后自己试试能不能写出来插件吧QAQ*()

因此我回到了以前开发时用过的phpstorm, 给phpstorm配置laravel插件, 操作很简单, 不过要注意版本的兼容问题.

1. (其实没有顺序啦) 安装PhpStorm的Laravel Plugin

在phpstorm里连按两下Shift ,打开指令输入窗口,输入 Plugin,  选择 Install Plugin, 搜索laravel插件并且安装.

2.使用Composer 安装 laravel-ide-helper

这个laravel-ide-helper插件是我们要想让上面的插件实现补全的必备依赖, 如果不安装这个插件的话是没有办法使用laravel的补全的功能的, 而这个插件安装的版本要和自己的laravel版本配套

  • 使用的是 4.2.*版本的laravel 需要安装1.11.*的插件
  • 5.* 版本的安装2.*的插件

注意如果版本不匹配是不能安装成功的 , 会提示你缺少依赖

 

附上laravel-ide-helper插件的地址: Laravel-Ide-Helper

Comments are closed.